Menu Items Greyed out in Ubuntu

KildClient forum.
Post Reply
Shane
Posts: 1
Joined: Fri Mar 07, 2014 5:28 pm

Menu Items Greyed out in Ubuntu

Post by Shane »

Heya. I was so happy to see a new option for Linux mudding. I use Mudlet, but I have issues with it formatting colored text and have NO idea how to fix, or if it CAN be fixed. A test run with Kildclient confirms though it is definitely something specific to Mudlet.

Sadly, Kildclient is not behaving well either. Instead of the menu showing up on the window for Kilde, it only shows up at all, if it shows up, on the Ubuntu menu at the top. It shows basically when the Kildeclient window is active and a world is connected. If no world is connected, the menus for World, Preferences, and Help don't even show up.

And the kicker. Whether or not I get the menu items, everything is greyed out.

I know Ubuntu has made its own little desktop after Gnome teed everyone off, and Ubuntu it seems has gotten flack for ITS desktop as well. No doubt this has something to do with that. If anyone knows if or how I can fix it, please drop me a response.

I can hobble through running most of the program using the listed keyboard shortcuts. Still, it would be nice for it to function as designed.
ekalin
Site Admin
Posts: 40
Joined: Sun Feb 05, 2012 3:59 pm

Re: Menu Items Greyed out in Ubuntu

Post by ekalin »

I don't know how the Ubuntu menu-on-top-bar actually works. But I seem to remember reading that it wasn't very well received and may be reverted in a future version.

When no world is open, you should get the "Open World" window. That window has no menus, and since it's a modal window, you cannot select menu items when that window is open.

I'm not sure exactly what you're trying to achieve. If when you're disconnected from a mud you select "Offline" from the dialog that opens, you can continue using the menus and interacting with the main window.
jmud
Posts: 19
Joined: Mon Jun 04, 2012 4:59 am

Re: Menu Items Greyed out in Ubuntu

Post by jmud »

Shane,

Are you sure that your MUD is using real ANSI colours?

I've noticed a number of MUDs using slightly different ways of sending text colours; as a result, the text in the client window gets some of the colours right, but others wrong. This can lead to the illusion of a client apparently failing to interpret colorus correctly.

The solution is to find out how to switch the MUD's terminal type to ANSI - it might as typing the command 'term ansi'.
Post Reply